Freemindscafe

Microphone not working with Microsoft Teams on Ubuntu (Solved)

From last many days, my kids are taking their class online. I am using one laptop having Ubuntu 20.04 as operating system. I was facing one issue consistently and that was microphone was not behaving properly. Sometimes it will work and other times it will not. After trying out various options and exploring internet, the following changes worked for me.

Login as a root user to your system GUI and not as some other user. This alone should solve the issue.

If you have not enabled root login for GUI and you are logged in as some other account say ‘user1’, then perform the following steps.

  • Set the root password. Open the terminal and type following

$ sudo passwd

  • Edit the /etc/gdm3/custom.conf file to allow the root login. Add the highlighted line.


  • Edit the /etc/pam.d/gdm-password file and comment out the line that denies the root access to GUI. Comment out the highlighted line.


  • Reboot the system and use root user for the login to GUI. On the login screen use Not Listed? Option.
  • If your system doesn’t have the pulseaudio, install it now.

$ snap install pulseaudio

  • If it was already installed, verify it is running. Use the following command. The output should show pulse audio running as root user.

  • Verify that the teams application is also running as root user. Use the following command. The output should show teams running as root user.

Ideally by now if you try to open the teams app and try to use internal/external microphone, it should work.
Understanding pulse audio control will help you to decipher the hidden stuff.

Understanding pulse audio control (This will ensure that there are no hiccups in future)

  • Open pulse audio control by searching for it in applications.
  • The configuration tab lists all the hardware devices and their profiles (Card and Card Profiles in puse audio terminology). 1st one is Build-in Audio with HDMI Output as profile, 2nd one is Build-In Audio with Analog Stereo Duplex as profile and 3rd one is Jabra SPEAK 410. Take a not of their profiles. 2nd one has duplex profile as it can play the sound as well as can receive the sound using microphone. 3rd one also has been set for output and input. Since I have no active HDMI connection that’s why 1st one shows as unplugged profile and one can only output the sound to other devices using HDMI, the profile is output only.

2020-09-12_13-02

  • The Input Devices tab shows that there are two input devices one the internal microphone and the other Jabra SPEAK 410 Analog headset microphone. Since on HDMI, we can not receive the sound, it is not listed here.
  • The output devices are also listing two devices build-in audio and Jabra. The third one is HDMI and since I have not plugged in any HDMI cable that’s why it shows as unplugged.
  • The playback tab lists down all the applications that are sending out sound to output devices. Since the only app that was producing the sound when I took the screenshot was youtube and it was opened in firefox. It shows application as firefox. Also the selected device is ‘Built-In Audio’. We can choose Jabra from this drop down and then the firefox will start sending the sound to Jabra speaker.
  • The recording tab displays all the application that are receiving the sound and on which device. Since right now no application was receiving the sound, it says no application is currently receiving the audio.
  • I then started the teams application and saw Skype there in the Recording tab. Now you can choose which device teams should use for recording. You can use either Jabra or Build-in Audio. Please ignore the devices starting with Monitor as these devices are internally created and used by pulseaudio for buffering I guess.

References